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Raster editing 
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Formatting a raster image 

1. Inserting a raster image 

1.1. Create a new document 

1.2. Insert a raster image with the Insert Image command:   

Ribbon: Raster>Image from File or Menu Raster>Image from File 

 

1.3. In the window that opens, click the Browse button, and find the Bushing.tif file. 

1.4. Specify the insertion point on the screen and click OK. A raster frame (border) will 

appear in the model space, left click anywhere in the model space. 

2. Correcting color image by histogram 

2.1. Choose the Equalize  command (Ribbon: Raster>Equalize or Menu>Raster 

>Processing the raster>Equalize. 

2.2. Set the threshold for dark tones. Using a dark eyedropper (take a sample for the 

lowest mark), specify on the screen the color that should turn black (select one of 

the lighter pixels on the black part of the image). 

 

Then set the threshold value for light tones. Using a light eyedropper (take a sample for 

the highest mark), indicate on the screen the color you want to convert to white (select one 

of the dark pixels in the background). 
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2.3. Click Apply. 

All pixels with a brightness value below the dark threshold will receive a brightness 

value of zero, and pixels with a brightness value higher than the brightest will 

receive the maximum brightness value 

3. Converting a color image to monochrome 

3.1. Select the Binarization command (Ribbon: Raster>Processing> 

Binarization or Toolbar Modify Raster>Binarization) 

3.2. In the Binarization dialog box, select the Threshold tab. 

3.3.  On the loaded raster, select the part of the raster that interests us most by clicking 

on the raster with the cursor (you can see a red frame on the screen showing the 

boundaries of the viewport) 

 

 

3.4. On the Threshold tab, select the Range tab by Gray and channel tab Gray. 

3.5. Select the threshold values Threshold value using the G slider. 

3.6. Click Apply. 

3.7. A new monochrome raster will be created on top of the original gray color raster. 

3.8. The original raster can be deleted. 
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3.9. Click the LMB (left mouse button) on the border of the raster, in the dialog box that 

appears, select the source raster and press the Delete button on the keyboard. 

 

4. Speckle Remover 

4.1. Start the command from the Ribbon: Raster>Filters> Speckle Remover 

or Toolbar Raster>Filters>Speckle Remover. 

4.2. Set the size of the raster speckle using the Measure maximum size button  

 
4.3. To measure the size of a raster object on the screen, click the button and specify a 

point inside the object 

4.4. Click Apply. 
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4.5. Raster speckle can also be removed automatically, if check the Auto estimating 

box to let the filter estimate the size of the raster “speckle” before filtering. Each 

click on the 'Apply' button will remove a speckle, first smaller, then larger and 

larger. Remove the remaining large speckle using the selection tools. 

4.6. Enable the selection set creation (Ribbon: Raster>Raster Selection> 

Add or Toolbar Raster Select>Add). 

4.7.  Run the command Inside rectangle (fill)  (Ribbon: Raster>Raster 

Selection>Select Inside Window Flood Fill or Toolbar More raster Select> 

Select Inside Window Flood Fill). 

 

4.8. Use a rectangular frame to select garbage, finish forming the selection set by 

pressing Enter. Delete the selected areas by pressing the Delete button. 

5. Eliminating image distortion 

5.1. Add empty margins to the image from all sides. To do this, run the Change Size 

command  (Ribbon: Raster>Modification>Change Size or Toolbar 

Raster>Change Size). In the Alignment/Margins box, add 5mm blank margins 

on four sides. 
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5.2. Click ОК. 

5.3. Since the outer frame of the stamp is partially lost in the drawing, carry out the 4-

point correction using the inner frame of the drawing. To do this, you need to adjust 

its dimensions. 

5.4. Open the Settings dialog box (Ribbon: Manage>Options or Toolbar 

Tools>Options). Open the Paper Formats section, highlight the ISO A4 format 

(210.00 x 297.00 mm) and click Modify. 
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5.5. In the dialog box that opens, enable the Internal Frame checkbox and set the 

dimensions for the internal frame of the A4 stamp (portrait orientation). 

 

5.6. Click ОК in Modify paper format and click OK in the Options dialog. 

5.7. Run the 4-point Correction  (Ribbon: Raster>Modification>4 Point 

Correction or Toolbar Raster Modify>4 point Correction). 

5.8. In the dialog box, select ISO A4 format, enable Use Internal Page Frame and set 

portrait orientation.  

 

5.9. Click Measure Frame  and consistently indicate the four corners of the internal 

frame. 
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5.10. Click ОК. 

 

6. Replacing the raster stamp of a drawing with a vector drawing  

6.1. We will use a ready-made A4 format. 

Open Ribbon: Insert>Reference>DWG Reference  
 

6.2. In the window that opens, select the Forum_F4.dwg file and click OK. 
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6.3.  Set the vector frame next to the raster. 

Then move (Ribbon: Home>Modify>Move or Toolbar Modify>Move) and put a 

vector frame on a raster frame (as a base point, select the lower-left corner of the 

inner frame of the drawing). 
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6.4. After the overlay, press Esc to deselect. 

 

6.5. Remove the raster frame and stamp of the drawing. Select all raster with the Select 

All command  (Ribbon: Raster>Raster Selection>Select All or Toolbar 

Raster Select>Select All) 

Exclude raster graphics that you want to keep from the selection. Enable Exclude 

mode  (Ribbon: Raster>Raster Selection>Remove or Toolbar Raster 

Select>Remove) and additional selection methods (Ribbon: Raster>Raster 

Selection>Select Inside Window Flood Fill or Toolbar More raster Select> 

Select Inside Window Flood Fill  select the part type, part designation and 

name, scale and material.  
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To delete the selected information, press the Delete key.  

 

7. Making changes to a drawing 
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Edit the drawing number and product name. Run the Editing Raster Text 

command (Ribbon: Rasterize> Editing Raster Text). Draw a rectangular border 

around the text you want to change, starting from the horizontal baseline.  

7.1. Enter a new text and press Enter. A new vector text appears on top of the original 

bitmap text. 

 

 

7.2. Select No to rasterize the text. 

7.3. Select the received vector text and set the necessary parameters in the Properties 

bar, for example, style - Standard, Height - 7, Obliquing - 15 
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7.4. Press Esc to exit. 

7.5. Edit the text in other fields in the same way. For the turned text, you need to set the 

rotation angle in the properties – 180. 

8. Rasterizing and saving a document 

8.1. Select all vector data 

 

 

8.2.  Run the Rasterization command with the deletion of the selection (Ribbon: 

Raster>Rasterize>Merge or Toolbar>Raster Modify>Merge). 

 

 

8.3. Trim the empty fields automatically. Run the Crop Raster command automatically 

(Ribbon: Raster>Modification>CropAuto or Toolbar>Raster 

Modify>CropAuto). 
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8.4. To save the result, open the External references dialog box (Ribbon: 

Insert>External References). Highlight the link to Bushing0, which has the 

Embedded status and click Save As…. 

 

 

8.5. In the dialog that opens, specify the file name, file type (TIFF) and click Options. 

8.6. On the Monochrome tab, configure the settings for saving the TIFF format. 

 

Click OK 

Click Save. 

Close the External References dialog. 
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Converting raster graphics to vector format  

Open file NC_Mech.dwg. (…\TestDrive-Raster\) 

 

 

1. Setting conversion parameters  

1.1. Run the R2V Conversion Options command (Ribbon: 

Raster>Conversion>R2V Conversion Options or Toolbar Raster to Vector> 

R2V Conversion Options). 

1.2. On the Recognition tab, mark Lines (line types and arrows), Arcs and Circles (line 

types and arrows), Text Area (OCR), Hatches (±45°).  
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1.3. On the Options tab, set the maximum width, maximum break, text height, arrow 

size, set the accuracy and adjust the orthogonalization.  

 

1.4. To set the maximum width, press  Measure the value opposite to the Maximum 

thickness field and cross the widest line of the drawing. The resulting value makes 

sense to increase slightly.  

 

In this example, set the maximum thickness 1.5 mm.  

 

1.5. Set the maximum ignored break in raster lines. Set the break to 0.5 mm. 

1.6. To set the height of the text, click  Measure the value opposite to the Text 

Height field and measure the maximum height of the text. 
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1.7. To set the size of the arrow, click  Measure the value opposite to the Arrow 

Size field and circle the arrow with a rectangular frame. 

 

1.8. Set the accuracy to low values and enable orthogonalization. 

1.9. On the Separate tab, configure the properties of the vector objects to be created 

(width, layer, color). 

1.10. To divide the interval (from 0 to 1.5 mm) into several ranges (from 0 to 0.8 

mm and from 0.8 mm to 1.5 mm), left-click in the appropriate place in the ruler of 

the thickness table. 

 

1.11. Enable the Use Table checkbox. 

1.12. For the first range, set the width - 0.25 mm, layer - 1, color - red. For the 
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second one, set the width - 0.5 mm, layer - 2, color - green. 

 

1.13. On the Texts tab, set the horizontal and vertical orientation of the text, 

include Free-standing letters, set the file with OCR characters default.ocr.  

 

To configure OCR, you need to specify a set of word templates. A word pattern is a rule 

that specifies the allowed sequence of characters within a single recognized word. The 

OCR module will recognize only those words that match one of the specified patterns. 

Buttons Add template and  Delete Template control the composition of the list of word 

templates. 

The following is a formal description of the definition of the word template: 

[% [length] character type] || [letter]] … 

Parameters for defining a word template 

Parameter Value 

[%] Beginning of character sequence definition 

[length] Any decimal number; missing with variable length 

[type] Character Type (D, E, e, N, n, S) 

[letter] Single letter 

Encoding symbol types 

Character 

encoding 

Decryption 

D Digits 

E Upper case letters of the English alphabet (first alphabet) 
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Character 

encoding 

Decryption 

e Lowercase letters of the English alphabet (first alphabet) 

N Uppercase letters of the national alphabet. 

n Lowercase letters of the national alphabet. 

S Special characters (plus and minus signs, equal sign, etc.) 

%% Single character "%" 

[letter] Single character  

For example: 

The Rz%D pattern corresponds to words that start with "Rz", followed by any sequence of 

digits, for example, "Rz40", "Rz2.5", "Rz5000". 

The template %1N%n corresponds to the words of the national alphabet with the 

uppercase first letter, for example "Hanover", "Oslo". 

The template %D%% corresponds to the words of the following type: "20%", "1100%", 

"12.50%". 

The %DV template corresponds to the words of the following type: "5V", "220V", "13.8V”. 

In the Height Table field, specify the possible heights of the texts. If you check the box, 

when generating recognized texts, the OCR module will create text objects with heights 

from this list, rounding the recognized height to the nearest one specified in the list. 

The configured conversion parameters can be saved in the parameter set file (*.tpl) by clicking the 
Template button. 

  

 

The saved parameter set file can be used to process rasters of similar quality. 

 

1.14. To accept the conversion parameters, click OK. 

2. Vectorizing in trace mode 
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2.1. Trace the section A-A. Make Vector and Erase Raster mode (Ribbon: 

Raster>Trace >Make Vector and Erase Raster or Toolbar Raster to vector> 

R2V Convector) and Trace Auto  command (Ribbon: Raster>Trace> Trace 

Auto or Toolbar Raster to Vector>Trace Auto). 

 

2.2. To trace the axial and extension lines, enable the Line command  (Ribbon: 

Raster>Trace>Line or Toolbar Raster to Vector>Line). Specify the start and end 

points of these lines. 

 

2.3. If necessary, use nanoCAD to adjust the received vectors (extend to the border, 

cut along the border) and change the type of lines. 

2.4. Hatching in a closed contour is performed by means of nanoCAD. 

2.5. Hide the raster display  (Ribbon: Raster>Visualization>Hide Raster). 
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2.6. Create a hatching  (Ribbon: Draw>Add Hatch or Toolbar Draw> Add 

Hatch).  

 

2.7. Set the type - Standard, sample - ANSI31, scale -1. 

2.8. Click the button  Add: Select points and specify the points inside the hatching 

contours. 

 

 

2.9. Press Enter and in the Hatch window press Ok. 



22  

 

 

3. Automatic vectorization 

3.1. Turn on the raster display  (Ribbon: Raster>Visualization>Hide Raster). 

3.2. Run the Raster to Vector  command (Ribbon: Raster>Conversion> Raster 

to Vector or Toolbars Raster to Vector>R2V Convector). 

 

 

On the A-A section, a second hatching may appear (one from vectorization in trace mode, the 

second from automatic vectorization). Select one of the hatches and delete it. 

 

 


